今天用了一款程序使用的是python 2.7.*,但是CentOS 6中默认使用的python版本是2.6,故需要升级版本。

(1)要确保yum可以使用,如果卸载了默认的python 2.6
a.到安装盘的Packages中找到python2.6的rpm包

b.执行rpm -Uvh –replacepkgs rpm包名称.rpm 安装原有python版本,使得yum可以工作

(2)先安装GCC,用如下命令(安装python之前,最好确认一下gcc是否安装,否则./configure 阶段就会报错了。)

yum install gcc gcc-c++

(3)下载2.7.5

wget https://www.python.org/ftp/python/2.7.5/Python-2.7.5.tar.bz2

如果wget下载速度太慢,可以用迅雷下载到本地然后上传

(4)开始安装

tar jxvf Python-2.7.5.tar.bz2
cd Python-2.7.5
./configure
make
make install

(5)正常情况下即使python2.7安装成功后,系统默认指向的

所以要将系统默认的

/usr/local/bin/python2.7 -V
 mv /usr/bin/python /usr/bin/python.bak
ln -s /usr/local/bin/python2.7 /usr/bin/python

(6)修正yum报错:
a. 此时运行yum命令,会报错了。提示python版本不对。所以要把yum依旧指向老的python2.6版本:

vi /usr/bin/yum

b. 在打开的文件里的头一行,也就是指定python环境的那行代码,修改成:

/usr/bin/python2.6